W210 2001 E55. Some problems.

1995-Present : E200, E220D, E240, E290TD, E300, E300TD, E200, E240, E250, E280, E300, E320, E420, E430, E350, E500 E55AMG, E63AMG & incl. blueTEC & BlueEfficiency, All CLS models
Post Reply
christohill
Dernburg Wagon
Posts: 8
Joined: Mon 30 Mar, 2015 6:24 pm
Model you own: w210
Region: Victoria
Location: Nth Grampians shire

W210 2001 E55. Some problems.

Post by christohill » Fri 02 Nov, 2018 7:02 pm

Hello everyone, I just purchased a W210 2001 (facelift) E55; I love it but it does have a couple of issues, one of which I did not notice on the test drives. The first issue is that the headlight washers won't activate when I press the button the dash, they won't pop out at all. The second issue is the right rear window won't go down or up, I assume this is the window regulator issue that is a common occurrence? The third issue is the drivers seat pump thing won't work, is this expensive to fix?

The last issue and the most annoying is the car is an absolute beast but sometimes just feels like an absolute slug. I'll be driving and put my foot to the floor and it'll take off like a scalded cat, then a few minutes later i'll be driving, do the same thing and it'll just sit there, taking a while to actually pick up. I have done a soft ECU reset (I think I did it right) but what else could it be? The Mass Airflow Filter Sensor? Sometimes when i'm at a standstill i'll floor it and it won't take off for a couple of seconds, which makes it particularly dangerous coming out of an intersection.

Apart from that it's a great car.

Last but not least, could anyone recommend a specialist Mercedes mechanic near Horsham/Ararat/Stawell?

If anyone has any advice at all it would be much appreciated!

- Chris

christohill
Dernburg Wagon
Posts: 8
Joined: Mon 30 Mar, 2015 6:24 pm
Model you own: w210
Region: Victoria
Location: Nth Grampians shire

Re: W210 2001 E55. Some problems.

Post by christohill » Sat 03 Nov, 2018 9:42 am

I was driving it last night, the engine light came on and the transmission went into limp home mode. Oh dear.

- Chris

User avatar
Ivanerrol
Mercedes Demigod
Posts: 5852
Joined: Sat 12 May, 2007 2:21 pm
Model you own: w204
Location: Melbourne

Re: W210 2001 E55. Some problems.

Post by Ivanerrol » Sat 03 Nov, 2018 10:30 am

Limp home can be caused by a faulty MAF .

Faulty MAF could also explain your acceleration issues.

You need to get the codes read by a Mercedes Specialist - not your average mechanic with a scanner.

Window regulators are a common issue but can be DIY - there a UTube videos out there with instructions.
W211 - E240
W204 - C280
Departed
W202 - C200, C180, C180
W126 - 380SE , 380SE (Ex SA Import), 560SEL
W124 - 300e, 260e (ex Japan)
W111 220s (Indonesia) 4 speed manual column shift
W123 230
W116 450SEL
W140 420SEL
W210 E240, E240
W209 CLK 240
W201 190e 2.6 (ex U.K.)

christohill
Dernburg Wagon
Posts: 8
Joined: Mon 30 Mar, 2015 6:24 pm
Model you own: w210
Region: Victoria
Location: Nth Grampians shire

Re: W210 2001 E55. Some problems.

Post by christohill » Sat 03 Nov, 2018 12:19 pm

thanks for the reply Ivanerrol. The car is fine today, no engine light, good acceleration; but I am taking it to a specialist Mercedes mechanic next week to sort it out. I won't drive the car in the meantime. I'll tackle the window regulator by myself and see how I go with that.

- Chris

User avatar
Ivanerrol
Mercedes Demigod
Posts: 5852
Joined: Sat 12 May, 2007 2:21 pm
Model you own: w204
Location: Melbourne

Re: W210 2001 E55. Some problems.

Post by Ivanerrol » Sat 03 Nov, 2018 9:13 pm

One symptom of a crook MAF.
Car goes into Limp home mode. Stop car. Turn engine off - restart car - limp home gone away.

O.T.O.H. A faulty transmission conductor plate also exhibits the same symptoms.
W211 - E240
W204 - C280
Departed
W202 - C200, C180, C180
W126 - 380SE , 380SE (Ex SA Import), 560SEL
W124 - 300e, 260e (ex Japan)
W111 220s (Indonesia) 4 speed manual column shift
W123 230
W116 450SEL
W140 420SEL
W210 E240, E240
W209 CLK 240
W201 190e 2.6 (ex U.K.)

christohill
Dernburg Wagon
Posts: 8
Joined: Mon 30 Mar, 2015 6:24 pm
Model you own: w210
Region: Victoria
Location: Nth Grampians shire

Re: W210 2001 E55. Some problems.

Post by christohill » Wed 07 Nov, 2018 2:40 pm

someone mentioned it may be a throttle position sensor? In any case, i'll find out next Tuesday when I take it for a service.

In the meantime, the car has a Comand 2.0 system however it does not have the disc, I set the correct time and date, drive around and then the time and date change to 1999 because it's trying to get information from a satellite. Does anyone have any idea how to stop this from occurring? I attempted to change my country on the Comand system to "Australia" so it keeps the correct time however it doesn't list Australia.

- Chris

Post Reply

Return to “W210-W212 E-Class, C218-219 CLS class & C207 E-Class Coupé”