Wiper blade/&humming noise/engine pings on RON 91

1993-Present: C200 CDI, C220 CDI, C270 CDI, C180, C200 Kompressor, C230 Kompressor, C220, C230, C280, C300 C350, CGI & CDI BlueEfficiency variants
Post Reply
newMercowner69
Gelandewagen
Posts: 109
Joined: Tue 24 Feb, 2015 5:00 pm
Model you own: w202
Location: Melbourne, Australia

Wiper blade/&humming noise/engine pings on RON 91

Post by newMercowner69 » Sat 15 Sep, 2018 2:09 pm

Werner/Wilhelm's arm (wiper arm&blade),
Gets stuck when operated
The blade itself has come out too far,
Now it makes a loud humming noise,
When I switch/turn the wipers on. Also even though my owners manual states recommend RON is 91,
Lately over 2-3 weeks it pings,
Switched to United 98,
No pinging,
Strange, unusual &weird?.

User avatar
Chai
OZBENZ moderator
Posts: 655
Joined: Fri 04 Nov, 2005 11:49 am
Model you own: w107
Location: Melbourne

Re: Wiper blade/&humming noise/engine pings on RON 91

Post by Chai » Sat 15 Sep, 2018 8:34 pm

Regarding the engine pinging using RON91, try changing your petrol supplier and see if it makes a difference.
If not cured regardless of supplier, you can: de-tune the engine further, or use 95, or a cocktail of 91 and 98.

Chai
Chai
1974 450SLC

newMercowner69
Gelandewagen
Posts: 109
Joined: Tue 24 Feb, 2015 5:00 pm
Model you own: w202
Location: Melbourne, Australia

Re: Wiper blade/&humming noise/engine pings on RON 91

Post by newMercowner69 » Sun 16 Sep, 2018 8:29 pm

United 98 premium fixed&solved the pinging drama , issue &problem,
But now when I turn the Key in the ignition,
A loud humming noise comes thru the dash,
But disappears when engine is running &coasting,
Could this etc be electric fuel pump or wiper motor noise,
Even though wiper's not engaged?.

User avatar
John Green
OZBENZ Admin
Posts: 6593
Joined: Mon 20 Jun, 2005 3:49 am
Model you own: w112
Region: Australian Capital Territory
Location: Canberra-center of the known universe
Contact:

Re: Wiper blade/&humming noise/engine pings on RON 91

Post by John Green » Sun 16 Sep, 2018 9:30 pm

The mechanisum inside the wiper arm on these has to be cleaned and lubicated every few years to stop them from siezing and eventually breaking, yours maybe too late.

petrol is like wine and a few other things. You get what you pay for. I wouldn't put 91 in a lawnmower, its cheap nasty stuff....
Inaugural OZBENZ national meet this September, all welcome to attend. https://ozbenz.net/viewtopic.php?f=46&t=25165

M.B Spares & Service 14-16 Lyell St, Fyshwick ACT. Ph 02 6239 1099

http://mbspares.com.au - Supporting Australia's Mercedes-Benz Enthusiasts.

newMercowner69
Gelandewagen
Posts: 109
Joined: Tue 24 Feb, 2015 5:00 pm
Model you own: w202
Location: Melbourne, Australia

Re: Wiper blade/&humming noise/engine pings on RON 91

Post by newMercowner69 » Mon 17 Sep, 2018 1:16 pm

The humming noise i suspect may etc be wiper motor?,
It disaapears once engine's running,
Only happens/occurs after engine's started or ignition is switch to auxilary.

newMercowner69
Gelandewagen
Posts: 109
Joined: Tue 24 Feb, 2015 5:00 pm
Model you own: w202
Location: Melbourne, Australia

Re: Wiper blade/&humming noise/engine pings on RON 91

Post by newMercowner69 » Tue 18 Sep, 2018 9:35 pm

Now appears &seems wipers DON'T&WON'T come on when switch is activated/engaged/turned on,
I'll check the fuses but diagnosing &suspecting wiper motor,
Who supplies Benz as O E. wiper motor manufacturer &supplier?,
Is it : Febi-Bilstein or Bosch/Valeo?.

Post Reply

Return to “W202-w205 C-Class Sedan, Estate & Coupe”