Goes but won't stop

1953-1961: 180, 180a, 180b, 180c, 180D, 180Db, 190, 190b, 190D, 190Db, 220a, 220S, 220S cabrio., 220S coupe 220SE, 220SE coupe, 220SE cabrio.
Post Reply
Johnnojack
Dernburg Wagon
Posts: 5
Joined: Sat 12 May, 2018 10:51 pm
Model you own: w201
Region: South Australia
Location: Adelaide

Goes but won't stop

Post by Johnnojack » Fri 13 Jul, 2018 9:43 pm

My 190D has stopped stopping, that is it won't turn off. I have figured out it is the ignition vacuum switch which is either faulty, leaks or has a vacuum line off. The engine can be stopped by sucking on the line to the 'stopping vacuum pot' what is it called? onthe IP. I'm very time poor at the moment so don't want to start pulling the dashboard apart to get out the switch and then finding another one. If I connect a common vacuum switch to the engine shutoff and switch it with power from the ignition will it work?

User avatar
Tony From West Oz
OZBENZ moderator
Posts: 3222
Joined: Mon 20 Jun, 2005 9:04 pm
Model you own: w202
Location: Bedfordale WA

Re: Goes but won't stop

Post by Tony From West Oz » Fri 13 Jul, 2018 10:32 pm

JJ
Yes a vacuum relay will work well in that application, that is how I did the vacuum shutdown on my 300CD.
Have a look at the vacuum "spider" near the firewall on the drivers side. The hose may have been knocked off it or has split.
You should really block off the hose for the shut down ignition switch, so it is not leaking vacuum.
Life is a journey, with problems to solve, lessons to learn, but most of all, experiences to enjoy.

'83 W123 300D 325000km (Wife's car Josephine - sold).
'84 W123 300D replaced good OM617 912 with OM617 952 and enjoyed having good acceleration for the first time since first driving a 300D in 2002 - became engine and trans donor for 300CD Turbodiesel conversion. Now parted out.
'86 W124 300D sold (Wife's old car - sold )
'85 W123 300CD, 275 000km (Fatmobile) rebuilt turbodiesel from previous Fatmobile transplanted into 280CE (SOLD)
'99 W202 C250 Turbodiesel (my darling Wife's car - Sold)
'98 W202 C250 Turbodiesel (my car - Sold)
'06 Ssanyong Musso Crew Cab 2WD Ute (OM662 diesel and Auto Transmission)

Johnnojack
Dernburg Wagon
Posts: 5
Joined: Sat 12 May, 2018 10:51 pm
Model you own: w201
Region: South Australia
Location: Adelaide

Re: Goes but won't stop

Post by Johnnojack » Mon 16 Jul, 2018 9:18 pm

Well I no longer have to keep popping the bonnet to stop my motor. I did however have a lot of trouble finding access to a point where I could connect to the +Ve wire from th 'ignition' switch, finally had to connect to the black wire to the radio. Removed the vacuum tube from the spider to the ignition switch and replaced it with a new tube to the new vacuum relay.
A side effect is that the auto trans up shift is smoother, maybe was losing vacuum to faulty ignition module?
I see I have posted this in the wrong subforum so happy to have it moved to the correct one. Ta.

Post Reply

Return to “W105, W120, W121, W180, W128 Sedans, Coupes and Cabriolets”