repairs to amplifier

1991- Present : 300SE, S320, 400SE, 400SEL, S420, 500SEL, S500, 600SEL, S600, 500SEC, S500, 600SEC, S600
S320 CDI, S320, S430, S500, S600, S55 AMG, S63AMG, S65AMG
Post Reply
User avatar
pina4greg
E Class
Posts: 52
Joined: Wed 10 May, 2017 12:53 am
Model you own: w140
Region: Western Australia
Location: Eglinton

repairs to amplifier

Post by pina4greg » Wed 06 Sep, 2017 12:48 am

Just sent off my amplifier to Factory Service Centre in Richardson Texas USA. Needs a rebuild so will let you guys know how it goes.
1992 W140 300se

User avatar
Ivanerrol
Mercedes Demigod
Posts: 5783
Joined: Sat 12 May, 2007 3:21 pm
Model you own: w204
Location: Melbourne

Re: repairs to amplifier

Post by Ivanerrol » Wed 06 Sep, 2017 11:17 am

Did you try Soundlabs in Australia?
There's also Supertech in Queensland.
W211 - E240
W204 - C280
Departed
W202 - C200, C180, C180
W126 - 380SE , 380SE (Ex SA Import), 560SEL
W124 - 300e, 260e (ex Japan)
W111 220s (Indonesia) 4 speed manual column shift
W123 230
W116 450SEL
W140 420SEL
W210 E240, E240
W209 CLK 240
W201 190e 2.6 (ex U.K.)

User avatar
pina4greg
E Class
Posts: 52
Joined: Wed 10 May, 2017 12:53 am
Model you own: w140
Region: Western Australia
Location: Eglinton

Re: repairs to amplifier

Post by pina4greg » Thu 07 Sep, 2017 2:37 am

Soundlabs wanted nearly $1200.00 to rebuild.
Read a few good reports about Lenny8410 so went with him.
1992 W140 300se

drewpasmith
Dernburg Wagon
Posts: 8
Joined: Tue 06 Dec, 2016 2:59 pm
Model you own: w201

Re: repairs to amplifier

Post by drewpasmith » Tue 28 Nov, 2017 3:29 pm

Just chipping in with my experience here.

I had my Bose amp rebuilt by Factory Service Centre a few years back and the whole experience was faultless.

User avatar
pina4greg
E Class
Posts: 52
Joined: Wed 10 May, 2017 12:53 am
Model you own: w140
Region: Western Australia
Location: Eglinton

Re: repairs to amplifier

Post by pina4greg » Wed 29 Nov, 2017 2:39 am

Drew, yes mine went well with only the occasional click or chirp when changing volume initially. Had to reinstall the small worm gear off the cd changer myself as the unit would not eject or change cd's.

Hope you enjoy your new purchase.... how many km has the W40 done?

Is there much work to do?

Cheers
Greg
1992 W140 300se

drewpasmith
Dernburg Wagon
Posts: 8
Joined: Tue 06 Dec, 2016 2:59 pm
Model you own: w201

Re: repairs to amplifier

Post by drewpasmith » Thu 18 Jan, 2018 11:13 am

Hi Greg,

I've owned her since 2013, so we know each other well :)

I imported her at the end of last year, after I moved back from the UK.

That being said, on a run from Byron back to Sydney, she destroyed he distributor and timing cover just south of Taree.

The mechanic is looking over her now and it's *not* pretty.

Cheers,

Drew

User avatar
Ivanerrol
Mercedes Demigod
Posts: 5783
Joined: Sat 12 May, 2007 3:21 pm
Model you own: w204
Location: Melbourne

Re: repairs to amplifier

Post by Ivanerrol » Thu 18 Jan, 2018 11:38 am

drewpasmith wrote:
Thu 18 Jan, 2018 11:13 am
Hi Greg,

I've owned her since 2013, so we know each other well :)

I imported her at the end of last year, after I moved back from the UK.

That being said, on a run from Byron back to Sydney, she destroyed he distributor and timing cover just south of Taree.

The mechanic is looking over her now and it's *not* pretty.

Cheers,

Drew
Is this a W140? If so which engine?
W211 - E240
W204 - C280
Departed
W202 - C200, C180, C180
W126 - 380SE , 380SE (Ex SA Import), 560SEL
W124 - 300e, 260e (ex Japan)
W111 220s (Indonesia) 4 speed manual column shift
W123 230
W116 450SEL
W140 420SEL
W210 E240, E240
W209 CLK 240
W201 190e 2.6 (ex U.K.)

drewpasmith
Dernburg Wagon
Posts: 8
Joined: Tue 06 Dec, 2016 2:59 pm
Model you own: w201

Re: repairs to amplifier

Post by drewpasmith » Fri 04 May, 2018 9:56 am

Hi there!

I'm so sorry I'm late responding to this.

As a 600 SEL, she's got an M120 V12.

She's currently for sale for spares or repair in the classified section of this site.

Cheers,

Drew

Post Reply

Return to “W140, W220 - W222 S-Class”