air in fuel ml270 not starting

1997- Present: ML320, ML430, ML55AMG, ML280CDI 4matic, ML320CDI 4matic, ML420CDI 4matic, ML350 4matic, ML500 4matic, ML63AMG 4matic, GL 320CDI, GL420CDI, GL450, GL550, GLK220CDI, GLK280, GLK350, GLK320CDI, GL350 CDI, GL400, GL500
Post Reply
User avatar
rolfson66
Posts: 2
Joined: Wed 01 Apr, 2015 8:04 pm
Model you own: w163

air in fuel ml270 not starting

Post by rolfson66 » Wed 01 Apr, 2015 8:58 pm

hi just wondering?? I have replaced all o rings in fuel lines.new lift pump non return valve fitted before new fuel filter and I still have air in fuel lines. as soon as I turn off it will not start again unless I use airo start,when running I can see air in fuel line coming from fuel filter? can anyone help?? love the car even with its little probs Thanks Rolf

User avatar
Tony From West Oz
OZBENZ moderator
Posts: 3232
Joined: Mon 20 Jun, 2005 9:04 pm
Model you own: w202
Location: Bedfordale WA

Re: air in fuel ml270 not starting

Post by Tony From West Oz » Wed 01 Apr, 2015 10:56 pm

Try replacing the O rings of the bolt that secures the filter to the housing.

Regards,
Tony
Life is a journey, with problems to solve, lessons to learn, but most of all, experiences to enjoy.

'83 W123 300D 325000km (Wife's car Josephine - sold).
'84 W123 300D replaced good OM617 912 with OM617 952 and enjoyed having good acceleration for the first time since first driving a 300D in 2002 - became engine and trans donor for 300CD Turbodiesel conversion. Now parted out.
'86 W124 300D sold (Wife's old car - sold )
'85 W123 300CD, 275 000km (Fatmobile) rebuilt turbodiesel from previous Fatmobile transplanted into 280CE (SOLD)
'99 W202 C250 Turbodiesel (my darling Wife's car - Sold)
'98 W202 C250 Turbodiesel (my car - Sold)
'06 Ssanyong Musso Crew Cab 2WD Ute (OM662 diesel and Auto Transmission)

User avatar
rolfson66
Posts: 2
Joined: Wed 01 Apr, 2015 8:04 pm
Model you own: w163

Re: air in fuel ml270 not starting

Post by rolfson66 » Thu 02 Apr, 2015 9:25 am

just had a look at fuel filter, mine is a sealed unit with intake and outlet at the top, the whole unit sits in a cradle with a bolt on the side to secure in place,i couldn't see where another o ring could go?
Thanks Rolf

User avatar
Tony From West Oz
OZBENZ moderator
Posts: 3232
Joined: Mon 20 Jun, 2005 9:04 pm
Model you own: w202
Location: Bedfordale WA

Re: air in fuel ml270 not starting

Post by Tony From West Oz » Thu 02 Apr, 2015 4:12 pm

OK, then it is different to other Mercedes diesel filters I have seen.
Someone else may be of some help to you.

Regards,
Tony
Life is a journey, with problems to solve, lessons to learn, but most of all, experiences to enjoy.

'83 W123 300D 325000km (Wife's car Josephine - sold).
'84 W123 300D replaced good OM617 912 with OM617 952 and enjoyed having good acceleration for the first time since first driving a 300D in 2002 - became engine and trans donor for 300CD Turbodiesel conversion. Now parted out.
'86 W124 300D sold (Wife's old car - sold )
'85 W123 300CD, 275 000km (Fatmobile) rebuilt turbodiesel from previous Fatmobile transplanted into 280CE (SOLD)
'99 W202 C250 Turbodiesel (my darling Wife's car - Sold)
'98 W202 C250 Turbodiesel (my car - Sold)
'06 Ssanyong Musso Crew Cab 2WD Ute (OM662 diesel and Auto Transmission)

Post Reply

Return to “W163-166, X164-166 & X204-205 ML, GL, GLK / GLC / GLS Class SUV's”