Resonance intake manifold switchover valve

1986-1995 : 200TD, 200CE, E200, 260E, 300E 2.6, 300E 2.8, 300E, E320, 400E, E420, 500E, E500, 300CE, E320, 230TE, 300TE, 300D 2.5 TURBO, E300 DIESEL, 300TD, 300E 4MATIC, 300TE 4MATIC, E36 AMG
Post Reply
nitchioo
Dernburg Wagon
Posts: 5
Joined: Thu 05 Jul, 2018 11:53 am
Model you own: I own multiple different models
Region: Australian outlaying islands-Territories
Location: MOWBRAY

Resonance intake manifold switchover valve

Post by nitchioo » Mon 16 Jul, 2018 3:21 pm

Hi all,

I have a M104 engine with the HFM-SFI system. My analog code reader is persistently retrieving this code 46 from Pin 8.
The analog code explanation is: Resonance intake manifold switchover valve - open/short to ground or B+

Part of the 'MB Diagnostic Manual for Engines 09/00' gives 3 possible digital codes:

105 - Resonance intake manifold switchover valve (Y22/6) short circuit to plus
106 - Resonance intake manifold switchover valve (Y22/6) open/short circuit to ground
107 - Control of ignition coil preloading voltage exceeds limits (starting 06/93)

Since my VIN plate states built April '93, I have ruled out digital code 107 (correct assumption?).

The 'MB Diagnostic Manual for Engines 09/00' lists a Test step/Remedy : 23 => 33.0 for digital codes 105 & 106.
I don't have the rest of this diagnostic manual. If someone has the manual, would you mind sharing the Test step/remedy information please.

This is the last code to remove in a long saga. I will elaborate if I can't get this information.

regards,

Ben
210065 E320 5sp. Auto Sedan (green-black) Avant-garde
124088 300TE_2.8 4sp. Auto Estate (blue-black) Classic
124023 230E 4sp. Auto Sedan (silver-gold) Classic

nitchioo
Dernburg Wagon
Posts: 5
Joined: Thu 05 Jul, 2018 11:53 am
Model you own: I own multiple different models
Region: Australian outlaying islands-Territories
Location: MOWBRAY

Re: Resonance intake manifold switchover valve

Post by nitchioo » Sat 25 Aug, 2018 1:31 am

Image
You do not have the required permissions to view the files attached to this post.
210065 E320 5sp. Auto Sedan (green-black) Avant-garde
124088 300TE_2.8 4sp. Auto Estate (blue-black) Classic
124023 230E 4sp. Auto Sedan (silver-gold) Classic

CraigB
OZBENZ Admin
Posts: 4961
Joined: Thu 23 Jun, 2005 1:18 pm
Model you own: I own multiple different models
Location: Hawthorndene (Adelaide)

Re: Resonance intake manifold switchover valve

Post by CraigB » Sat 25 Aug, 2018 9:46 am

I see no responses to your earlier question, that level of question is out of my league and for a lot of us but hopefully someone sees it that can help. I wasn't sure what the image was for but gather that was a prompt. Makes it all harder when your on an island i guess.
Craig Baulderstone
Lurch
280s's
280SE3.5
280SL
350SL
500SEC's
560SEL's

nitchioo
Dernburg Wagon
Posts: 5
Joined: Thu 05 Jul, 2018 11:53 am
Model you own: I own multiple different models
Region: Australian outlaying islands-Territories
Location: MOWBRAY

Re: Resonance intake manifold switchover valve

Post by nitchioo » Sun 26 Aug, 2018 12:59 am

CraigB wrote:
Sat 25 Aug, 2018 9:46 am
I see no responses to your earlier question, that level of question is out of my league and for a lot of us but hopefully someone sees it that can help. I wasn't sure what the image was for but gather that was a prompt. Makes it all harder when your on an island i guess.
thanks Craig,
Posting here was sorta my last resort. Google searched the hell out of the subject but gleamed little from all the effort.
The picture was in reference to the second last line of my post. I believe this is the manual I might need to explain the code properly - but not sure.
Maybe someone can kindly elaborate.
210065 E320 5sp. Auto Sedan (green-black) Avant-garde
124088 300TE_2.8 4sp. Auto Estate (blue-black) Classic
124023 230E 4sp. Auto Sedan (silver-gold) Classic

CraigB
OZBENZ Admin
Posts: 4961
Joined: Thu 23 Jun, 2005 1:18 pm
Model you own: I own multiple different models
Location: Hawthorndene (Adelaide)

Re: Resonance intake manifold switchover valve

Post by CraigB » Sun 26 Aug, 2018 10:09 am

These posts can be easy to skim over, particularly if busy, so hopefully a couple of extra posts might raise attention from those that know this sort of stuff and might have missed it.
Craig Baulderstone
Lurch
280s's
280SE3.5
280SL
350SL
500SEC's
560SEL's

User avatar
scorchi0
500 K
Posts: 534
Joined: Wed 15 Feb, 2012 11:40 pm
Model you own: w124
Location: Perth, WA

Re: Resonance intake manifold switchover valve

Post by scorchi0 » Sun 02 Sep, 2018 7:35 pm

See the pic attached for diagnostic test steps 33.0 & 33.1.
Diag test steps.JPG
If you're not familiar, it states to connect the tester breakout box to the engine ECU and connect to pins 58 & 39 on it. However, like most of us you may not have said piece of special equipment, so you need to find pin 14 on plug 2 and pin 39 on plug 1 of the ECU (the numbers shown in brackets). You need to connect on to these pins while the harness is still plugged in to the ECU.

Those pins connect straight to the resonance switchover valve, located in the middle of intake runners 3 & 4, so that's the easiest place to connect on to the wires.

Above 3900rpm, you should see 11-14V, below 3900rpm it should be 0V. If not, it states the possible remedy/cause of the issue is with the engine ECU, though i'd be checking wire continuity between the above mentioned ECU pins and the switchover valve. It also states to carry out step 33.1 if the desired values are achieved.

Basically, you need to narrow it down by finding out the following. Does the ECU supply power? If so, does the switchover valve draw the desired current when actuated? If no, then check wiring & fuse or replace the valve. If yes, then you have an intermittent fault.....

Hope that helps!

Trent
You do not have the required permissions to view the files attached to this post.
1991 S124 300TE - Smoke Silver
1993 C124 320CE - Brilliant Silver
Image Image

Post Reply

Return to “W124”