Horn fuse gremlins - check your horn button!

1986-1995 : 200TD, 200CE, E200, 260E, 300E 2.6, 300E 2.8, 300E, E320, 400E, E420, 500E, E500, 300CE, E320, 230TE, 300TE, 300D 2.5 TURBO, E300 DIESEL, 300TD, 300E 4MATIC, 300TE 4MATIC, E36 AMG
Post Reply
User avatar
MaXim
C Class
Posts: 46
Joined: Mon 15 Aug, 2016 10:05 am
Model you own: w123
Location: Melbourne VIC

Horn fuse gremlins - check your horn button!

Post by MaXim » Mon 05 Jun, 2017 10:03 am

Hey all,

Recently had a hilariously annoying issue on my 1988 300E.

It first began as I was driving out of Chadstone S.C. - Found that my indicators, interior temp gauge and horn stopped working! Luckily my girlfriend was with me so I got her to help act as a left indicator.

When I got home I replaced the blown fuse #6 and all was good again..for about 2 weeks.

Fuse #6 blew again. This time the fuse would blow every time I turned the steering wheel! I figured that it could have been any of the things connected to fuse #6 but decided to check the steering wheel based on the heuristic.

After disassembling the steering wheel I found that the horn is built like this:

| Horn pad | Horn button | Steering wheel and steering column |

Where the horn button is held onto the steering wheel using four studs. The studs are connected to +12V , while the horn button is connected to the horn via a brass ring.

The issue that was occurring was that the studs are insulated from the steering wheel using plastic grommets. These grommets had deteriorated and collapsed - the remnants were rolling around inside the steering wheel, meaning the studs were shorting to ground (the steering wheel itself and the steering column). Simply propping these studs back up with some rubber vacuum hose solved the issue.

Curiously I've only seen this four-stud design used on these late 80s w124s. In the W201 and W124 with airbags a more failsafe leaf spring design is used to actuate the horn.

User avatar
pastelgrey300D
OZBENZ Admin
Posts: 3553
Joined: Wed 07 Feb, 2007 9:17 am
Model you own: w111
Location: Adelaide

Re: Horn fuse gremlins - check your horn button!

Post by pastelgrey300D » Mon 05 Jun, 2017 11:50 am

Thanks for sharing! I wonder if this will become a common problem on these models as they all start to hit the 30 year mark?

Reminds me of a similar issue on an old Mitsubishi van I had - the horn pad had two contact plates behind it which were separated by a layer of foam (no springs). Every now and then the horn would just blow for no reason, then one day driving into work it just started to blow continuously (had to pull over and pull the fuse). I dismantled the steering wheel and found that the layer of foam separating the two contact plates had disintegrated and turned to dust!
David
1967 W111 230S - Horizonblau
1965 W110 190c - Mittelrot
1967 W110 200D - Weiss (work in progress)
+ other classics

Post Reply

Return to “W124”