E320 Engine stalls while driving and or will not always start

1995-Present : E200, E220D, E240, E290TD, E300, E300TD, E200, E240, E250, E280, E300, E320, E420, E430, E350, E500 E55AMG, E63AMG & incl. blueTEC & BlueEfficiency, All CLS models
Post Reply
User avatar
Grumpy
S Class
Posts: 89
Joined: Tue 25 Sep, 2012 7:46 pm
Model you own: w210
Location: Yackandandah Vic

E320 Engine stalls while driving and or will not always start

Post by Grumpy » Thu 01 Nov, 2018 6:12 pm

Howdy folks, I am looking to the brains trust here. My wifes E320 has decided that it does't want to start when warm. When it does start, it then runs for about 10klm's and refuses to start until it cools a bit. Or at least, that's what it appears to do. I initially diagnosed it as a fuel pump relay. I replaced it with immediate good results, however 30klm's later, it wouldn't restart for ages. What I do know is, the fuel pump relay is new and good. The fuel pump appears to be good, although I haven't done a pressure test. Filter good as well as coolant temperature sensor is good. I guess the crank sensor or cam sensor could be dodgy, however in my experience they don't appear to be consistent with the issue. So I am hoping someone has some good advice for me. It's a real good car, so it would be a pity if I decided to park it in one of my paddocks.

Kel
The Liver is Evil & must be Punished

W210 Elegance E320
Chrysler 300C Mercedes OM642 V6 Diesel and drive line.
Departed - W201 190E

CraigB
OZBENZ Admin
Posts: 5075
Joined: Thu 23 Jun, 2005 1:18 pm
Model you own: I own multiple different models
Location: Hawthorndene (Adelaide)

Re: E320 Engine stalls while driving and or will not always start

Post by CraigB » Thu 01 Nov, 2018 7:33 pm

I don't know your model but on a W126 a bad fuel accumulator can make warm starts difficult. Although once running its not normally a problem. Also on a W126 if I was suspicious that the new fuel pump relay could have an intermittent fault, you can bridge two of the pins so it runs constantly and that would just tip you off short term if it changed the behaviour. Just thought i would share that but hopefully and expert will soon follow with info.
Craig Baulderstone
Lurch
280s's
280SE3.5
280SL
350SL
500SEC's
560SEL's

User avatar
Grumpy
S Class
Posts: 89
Joined: Tue 25 Sep, 2012 7:46 pm
Model you own: w210
Location: Yackandandah Vic

Re: E320 Engine stalls while driving and or will not always start

Post by Grumpy » Thu 01 Nov, 2018 8:20 pm

Thanks Craig, yes, done the jumper wire trick. Doesn't help it start when it stops.

Kel
The Liver is Evil & must be Punished

W210 Elegance E320
Chrysler 300C Mercedes OM642 V6 Diesel and drive line.
Departed - W201 190E

User avatar
Ivanerrol
Mercedes Demigod
Posts: 5851
Joined: Sat 12 May, 2007 2:21 pm
Model you own: w204
Location: Melbourne

Re: E320 Engine stalls while driving and or will not always start

Post by Ivanerrol » Thu 01 Nov, 2018 10:14 pm

Are we a M104 or M112?

M104 temperature sensor can be suspect
W211 - E240
W204 - C280
Departed
W202 - C200, C180, C180
W126 - 380SE , 380SE (Ex SA Import), 560SEL
W124 - 300e, 260e (ex Japan)
W111 220s (Indonesia) 4 speed manual column shift
W123 230
W116 450SEL
W140 420SEL
W210 E240, E240
W209 CLK 240
W201 190e 2.6 (ex U.K.)

User avatar
Grumpy
S Class
Posts: 89
Joined: Tue 25 Sep, 2012 7:46 pm
Model you own: w210
Location: Yackandandah Vic

Re: E320 Engine stalls while driving and or will not always start

Post by Grumpy » Thu 01 Nov, 2018 10:31 pm

( Ivan) It's a w210 E320 2000 I isolated the coolant temp sensor and thought it fixed it. However it happened again. ie. did about 15k and it stopped and wouldn't start until it cooled down. Fuel pump made its usual sound when not starting.

Kel
The Liver is Evil & must be Punished

W210 Elegance E320
Chrysler 300C Mercedes OM642 V6 Diesel and drive line.
Departed - W201 190E

User avatar
Ivanerrol
Mercedes Demigod
Posts: 5851
Joined: Sat 12 May, 2007 2:21 pm
Model you own: w204
Location: Melbourne

Re: E320 Engine stalls while driving and or will not always start

Post by Ivanerrol » Thu 01 Nov, 2018 10:35 pm

Any fuel smells around the fuel pump?
2000 era we are in the era of computerization.
Also. 2000 - update or older model? Update has some more OBD built in.
W211 - E240
W204 - C280
Departed
W202 - C200, C180, C180
W126 - 380SE , 380SE (Ex SA Import), 560SEL
W124 - 300e, 260e (ex Japan)
W111 220s (Indonesia) 4 speed manual column shift
W123 230
W116 450SEL
W140 420SEL
W210 E240, E240
W209 CLK 240
W201 190e 2.6 (ex U.K.)

User avatar
Ivanerrol
Mercedes Demigod
Posts: 5851
Joined: Sat 12 May, 2007 2:21 pm
Model you own: w204
Location: Melbourne

Re: E320 Engine stalls while driving and or will not always start

Post by Ivanerrol » Thu 01 Nov, 2018 10:42 pm

I had a CPS fail on my W204.
Initially warm start failure. Cheap to buy the part but a bollocks to change over. - Didn't cause engine failure while in operation though.
Buy some MAF cleaner. Try that. MAF's are $$$$
W211 - E240
W204 - C280
Departed
W202 - C200, C180, C180
W126 - 380SE , 380SE (Ex SA Import), 560SEL
W124 - 300e, 260e (ex Japan)
W111 220s (Indonesia) 4 speed manual column shift
W123 230
W116 450SEL
W140 420SEL
W210 E240, E240
W209 CLK 240
W201 190e 2.6 (ex U.K.)

User avatar
Grumpy
S Class
Posts: 89
Joined: Tue 25 Sep, 2012 7:46 pm
Model you own: w210
Location: Yackandandah Vic

Re: E320 Engine stalls while driving and or will not always start

Post by Grumpy » Fri 02 Nov, 2018 10:17 am

Ivanerrol wrote:
Thu 01 Nov, 2018 10:35 pm
Any fuel smells around the fuel pump?
2000 era we are in the era of computerization.
Also. 2000 - update or older model? Update has some more OBD built in.
No smells, it's a good clean car, never had any problems. Yes it's an update model. I will try an crankshaft position sensor and see how I go :)

Kel
The Liver is Evil & must be Punished

W210 Elegance E320
Chrysler 300C Mercedes OM642 V6 Diesel and drive line.
Departed - W201 190E

User avatar
John Green
OZBENZ Admin
Posts: 6641
Joined: Mon 20 Jun, 2005 3:49 am
Model you own: w112
Region: Australian Capital Territory
Location: Canberra-center of the known universe
Contact:

Re: E320 Engine stalls while driving and or will not always start

Post by John Green » Fri 02 Nov, 2018 12:51 pm

My money would be on the crank angle sensor. Get a loom set up so that you can plug onto it when it wont start and see if it is open circuit. This is a typical failure, when it get hot it expands and goes open circuit, the engine control module doesn't know what the crank is doing, so it shuts down. Then the sensor cools and contracts once again making contact and away you go until it heats up again.
Inaugural OZBENZ national meet this September, all welcome to attend. https://ozbenz.net/viewtopic.php?f=46&t=25165

M.B Spares & Service 14-16 Lyell St, Fyshwick ACT. Ph 02 6239 1099

http://mbspares.com.au - Supporting Australia's Mercedes-Benz Enthusiasts.

User avatar
Grumpy
S Class
Posts: 89
Joined: Tue 25 Sep, 2012 7:46 pm
Model you own: w210
Location: Yackandandah Vic

Re: E320 Engine stalls while driving and or will not always start

Post by Grumpy » Thu 08 Nov, 2018 9:22 pm

All fixed and running like a dream again. Thanks for advice from others. It was the crank angle sensor. I managed to pick up one just around the corner from from a mate. Cheap easy fix, it took me about 20 minutes all up. Fortunately I had the correct tools for the job and many years of work experience :dance: .

Kel
The Liver is Evil & must be Punished

W210 Elegance E320
Chrysler 300C Mercedes OM642 V6 Diesel and drive line.
Departed - W201 190E

Post Reply

Return to “W210-W212 E-Class, C218-219 CLS class & C207 E-Class Coupé”