W211 E200K rough idle when cold

1995-Present : E200, E220D, E240, E290TD, E300, E300TD, E200, E240, E250, E280, E300, E320, E420, E430, E350, E500 E55AMG, E63AMG & incl. blueTEC & BlueEfficiency, All CLS models
Post Reply
Alex
B Class
Posts: 18
Joined: Wed 02 Jul, 2008 10:48 am
Model you own: w108

W211 E200K rough idle when cold

Post by Alex » Mon 03 Sep, 2018 10:10 am

Hi,
I have recently replaced my 1.8 litre motor (failure after 380,000km) and the new rebuilt motor runs very well but does not idle smoothly when cold.
My mechanic has not been able to solve this problem despite a number of attempts.
A summary of observations is as follows:
1. On cold mornings, the engine starts and idles at around 1200rpm in PARK. It is a smooth fast idle.
2. When placed in DRIVE, the revs drop to around 700-800 and it idles roughly and shakes.
3. Once I accelerate, the revs increase and power is very smooth.
4. Upon the engine reaching normal operating temperature, it settles to around 600 RPM at idle and smooth.

I would appreciate your advice on how to increase the idle speed when in DRIVE as part of the cold start. The original motor had no idle problems whatsoever and idled smoothly on cold starts.

Sincerely

Alex

User avatar
Ivanerrol
Mercedes Demigod
Posts: 5819
Joined: Sat 12 May, 2007 2:21 pm
Model you own: w204
Location: Melbourne

Re: W211 E200K rough idle when cold

Post by Ivanerrol » Mon 03 Sep, 2018 9:23 pm

380,000K's out of a modern turboed 4 cylinder :wave:

All engine controls on those engines are computerized so no real manual changing of settings such as idle speeds.

It will probably either be a sensor or some vacuum leak somewhere. How is the MAF?

Rebuilt engine - M211 or M271?
W211 - E240
W204 - C280
Departed
W202 - C200, C180, C180
W126 - 380SE , 380SE (Ex SA Import), 560SEL
W124 - 300e, 260e (ex Japan)
W111 220s (Indonesia) 4 speed manual column shift
W123 230
W116 450SEL
W140 420SEL
W210 E240, E240
W209 CLK 240
W201 190e 2.6 (ex U.K.)

Alex
B Class
Posts: 18
Joined: Wed 02 Jul, 2008 10:48 am
Model you own: w108

Re: W211 E200K rough idle when cold

Post by Alex » Tue 04 Sep, 2018 12:14 pm

Thanks for your response Ivanerrol.
The rebuild is an M271. I was expecting a little more than 380,000 km but perhaps this is unrealistic for a supercharged 4 cylinder.
My mechanic also thought it was a vacuum leak and has checked and replaced a number of vacuum related components without success.
He also cleaned the MAF housing and sensor.

Regards

Alex

Post Reply

Return to “W210-W212 E-Class, C218-219 CLS class & C207 E-Class Coupé”