Page 1 of 1

W202 Audio system

Posted: Wed 21 Apr, 2010 7:28 pm
by Markjw
Hi Guys,
I have a problem with the radio reception on the c200 1998 w202 I have just bought. Thanks to ivanerrol I know the antenna is in the back window. Does anybody happen to know where and how the antenna lead connects to the window and how to get to it. I think it had a broken back window at one stage and I would like to check the connection at the window. Also it had the Eurovox model 8790 in it with a cd stacker and the bose speaker system. However someone has put a cheap pioneer head in it and the stacker is disconnected. If anyone knows where there is a schematic drawing of the original system and could direct me to it I would appreciate it. I have a good JVC head unit I could put in and see how it goes but I don't know the inns and outs of the eight speaker system. I have thought about putting a compatible head unit in second hand and put it back to it's original system. I guess it depends on how the wiring behind the unit has been fiddled with as to what I do.
So if anyong has had any experience with this type of system I'd like to hear from you.
Thanks Mark

Re: W202 Audio system

Posted: Sun 25 Apr, 2010 12:00 pm
by Markjw
Update problem solved. Put the JVC head unit in, still the same poor reception no AM reception. Whilst I had it out and wired up I decided to put power to the Antenna control, now why would I do that seeming it's a hidden antenna and doesn't need power to raise the antenna now does it? Well low and behold the radio sprang into life. Beautiful AM and FM reception. The Blue and white antenna wire needed power to boost the signal. So I connected the antenna control wire from the JVC head, and the intire system is now working perfect. For others information the C200 wiring color code is as follows.
Brown/Earth, Pink & Green/constant power, Red/ Accessory power, Grey & Blue/light control when lights are switched on, Blue & White Antenna trigger in my case antenna booster. There is also a Green and Purple wire which is unknown to me, if anyone knows what this is for please let me know. :lol: :mrgreen:

Re: W202 Audio system

Posted: Mon 14 Jul, 2014 8:30 pm
by Tony From West Oz
Thanks for the assistance regaining AM reception in our W202 C250Ds.
I had different wire colours than you so recorded them in my post viewtopic.php?f=31&t=19616&p=140671#p140671

Regards,
Tony