w209 clk 320

Newcomers Please stop here first.
A wealth of information here to help you find your way through OZBENZ Forums
Post Reply
Denis Manley
Posts: 2
Joined: Mon 28 May, 2018 10:27 am
Model you own: w209
Region: Queensland
Location: Brisbane

w209 clk 320

Post by Denis Manley » Mon 28 May, 2018 10:41 am

I recently purchased a 2003 Clk 320
I have noticed a clicking in the dashboard several time at startup
it goes away aeverything appears to work
Any thoughts

User avatar
Ivanerrol
Mercedes Demigod
Posts: 5790
Joined: Sat 12 May, 2007 2:21 pm
Model you own: w204
Location: Melbourne

Re: w209 clk 320

Post by Ivanerrol » Fri 01 Jun, 2018 9:45 am

If you have an indash multi CD unit, it could be it sorting itself out at startup.
My W211 does the same thing.
W211 - E240
W204 - C280
Departed
W202 - C200, C180, C180
W126 - 380SE , 380SE (Ex SA Import), 560SEL
W124 - 300e, 260e (ex Japan)
W111 220s (Indonesia) 4 speed manual column shift
W123 230
W116 450SEL
W140 420SEL
W210 E240, E240
W209 CLK 240
W201 190e 2.6 (ex U.K.)

Denis Manley
Posts: 2
Joined: Mon 28 May, 2018 10:27 am
Model you own: w209
Region: Queensland
Location: Brisbane

Re: w209 clk 320

Post by Denis Manley » Tue 05 Jun, 2018 11:26 am

Ivanerrol wrote:
Fri 01 Jun, 2018 9:45 am
If you have an indash multi CD unit, it could be it sorting itself out at startup.
My W211 does the same thing.
Thanks
I will check it out
D

mw01
B Class
Posts: 20
Joined: Sat 30 May, 2015 8:47 pm
Model you own: I own multiple different models
Location: Tallarook, Vic

Re: w209 clk 320

Post by mw01 » Tue 05 Jun, 2018 6:14 pm

Our 203 had a very loud chattering behind the centre of the dash for 10 to 30 seconds after starting. It turned out to be the flaps in the air distribution box for the heater / air conditioner (not sure of the terminology). It made the noise until the flaps sorted themselves out and was then silent until the car had its next cold start. Long job to pull it all out to fix it. The indy workshop in Melbourne quoted me about $800 from memory so I did it myself. Cheers.
1982 380SEC
2002 C320 W203
2010 C250 CGI W204
2003 Alfa Romeo Spider 2000 JTS
1989 W201 190E 2.6 (sold)
Um.. Rodeo .. and ...Xtrail... for the ugly stuff.

User avatar
John Green
OZBENZ Admin
Posts: 6532
Joined: Mon 20 Jun, 2005 3:49 am
Model you own: w112
Region: Australian Capital Territory
Location: Canberra-center of the known universe
Contact:

Re: w209 clk 320

Post by John Green » Thu 07 Jun, 2018 12:47 pm

mw01 wrote:
Tue 05 Jun, 2018 6:14 pm
Our 203 had a very loud chattering behind the centre of the dash for 10 to 30 seconds after starting. It turned out to be the flaps in the air distribution box for the heater / air conditioner (not sure of the terminology). It made the noise until the flaps sorted themselves out and was then silent until the car had its next cold start. Long job to pull it all out to fix it. The indy workshop in Melbourne quoted me about $800 from memory so I did it myself. Cheers.
This is more likely to be your problem than the CD unit. It is very common..
Inaugural OZBENZ national meet this September, all welcome to attend. https://ozbenz.net/viewtopic.php?f=46&t=25165

M.B Spares & Service 14-16 Lyell St, Fyshwick ACT. Ph 02 6239 1099

http://mbspares.com.au - Supporting Australia's Mercedes-Benz Enthusiasts.

Post Reply

Return to “Welcome to OZBENZ!”