Becker 1402 strange characters

All about In-Car Entertainment (aka ICE)
Discuss audio problems in your mercedes / installs of new AV products
Share pics of your install, describe issues, troubleshoot audio electrics in your Mercedes.
Post Reply
User avatar
Charlie Buckett
C Class
Posts: 48
Joined: Sun 13 Sep, 2015 1:44 pm
Model you own: w124
Location: Victoria/Australia

Becker 1402 strange characters

Post by Charlie Buckett » Sun 13 Sep, 2015 3:07 pm

becker 1402.JPG
Hi!
I recently purchased a 300te, !!! soooo happy, but the becker 1402 has odd characters (see photo) and no sound. It takes a cassette, but still no sound, It never turns off unless I disconnect the battery or fuse.This model has no internal battery and does not need a code (although the previous owner paid $30 and was provided with a code). There are no leads for anti theft under the dash work, but there are signs of a previous phone/loudspeaker, I dismantled the thing completely, gave it some contact spray, looked for leaking capacitors, checked the fuse... Any ideas????
You do not have the required permissions to view the files attached to this post.

User avatar
T-Modell
SLS AMG
Posts: 2604
Joined: Mon 10 Apr, 2006 1:47 am
Model you own: w107
Location: Weinheim / Germany
Contact:

Re: Becker 1402 strange characters

Post by T-Modell » Sun 13 Sep, 2015 8:59 pm

Hi Charlie,

well my guess is that this display is fugged up (or the electronics controlling it). I think it's cheaper to get another - working - radio, than repairing this one. Would need to go to a Becker specialist ... Imho this only makes sense, if your car is 100% original and you want to keep the original radio too ...

Thomas
---------------------------------------------------------------
1967 W111 250SE Cabriolet, horizon blue
1973 W115 220D 5.0 Pick-Up Argentina, work in progress 2017/18
1986 R107 500SL, arctic white, the midlife crisis viagra replacement
2007 R171 SLK350, calcit white
2008 S211 E63T, calcit white, sleeper

User avatar
Charlie Buckett
C Class
Posts: 48
Joined: Sun 13 Sep, 2015 1:44 pm
Model you own: w124
Location: Victoria/Australia

Re: Becker 1402 strange characters

Post by Charlie Buckett » Sun 13 Sep, 2015 9:14 pm

Thanks for the reply, but it is more than the display, it does not make a sound, nor turn off. The cheapest replacement I can find is $300, and that is not cool for an outdated stereo that does not sound that good. I do want the original stereo though. If anyone has a 1402 or 780 becker for sale for less than $100 I would consider. But would prefer to fix this for less, I was told it worked when I purchased the car, grrrrr. Thanks

Djenka018
Ponton
Posts: 234
Joined: Sun 06 Aug, 2006 1:50 am
Model you own: w107
Location: Syd Vicious

Re: Becker 1402 strange characters

Post by Djenka018 » Mon 14 Sep, 2015 3:47 pm

This could be anything: simple as a broken track (liquid ingress rusting the tracks and shorting) or a cooked CPU.

If you really like it, I can try to repair it (got the service manual). If it is uneconomical to repair it, there would be no charge.
If you want a similar replacement - I have about a dozen of similar radios (may even have a spare 1402)
'80 450SLC 3-continental

User avatar
Charlie Buckett
C Class
Posts: 48
Joined: Sun 13 Sep, 2015 1:44 pm
Model you own: w124
Location: Victoria/Australia

Re: Becker 1402 strange characters

Post by Charlie Buckett » Mon 14 Sep, 2015 4:54 pm

1402.JPG
Thanks for reply. I would be happy enough to purchase a be780 or 1402 or any becker that will not need re-wiring. Are you in Oz? What kind of price would you ask? I will post a pic of the rear to be sure. Ta.
You do not have the required permissions to view the files attached to this post.

Djenka018
Ponton
Posts: 234
Joined: Sun 06 Aug, 2006 1:50 am
Model you own: w107
Location: Syd Vicious

Re: Becker 1402 strange characters

Post by Djenka018 » Tue 15 Sep, 2015 12:55 am

1402 was a premium model. Anything else will be a lesser model to it but from AM/FM performance perspective there was hardly any difference across the range.
I will check later this week what do I have in storage and workout price tags.
All my Becker radios would be plug-n-play replacement.
SydneyNSW
'80 450SLC 3-continental

User avatar
Charlie Buckett
C Class
Posts: 48
Joined: Sun 13 Sep, 2015 1:44 pm
Model you own: w124
Location: Victoria/Australia

Re: Becker 1402 strange characters

Post by Charlie Buckett » Tue 15 Sep, 2015 2:22 am

Thanks, I'm looking forward to having a stereo, I will be playing tapes as well (I tape my vinyl) Hope to hear from you soon.

User avatar
Charlie Buckett
C Class
Posts: 48
Joined: Sun 13 Sep, 2015 1:44 pm
Model you own: w124
Location: Victoria/Australia

Re: Becker 1402 strange characters

Post by Charlie Buckett » Wed 16 Sep, 2015 10:31 pm

Yay!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
I found one today at salvage for $20 that works perfect !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

User avatar
Merc-Star
Dernburg Wagon
Posts: 8
Joined: Tue 10 Nov, 2015 10:47 am
Model you own: w124
Location: Melbourne . Victoria

Re: Becker 1402 strange characters

Post by Merc-Star » Mon 23 Nov, 2015 5:25 am

Djenka018 wrote:This could be anything: simple as a broken track (liquid ingress rusting the tracks and shorting) or a cooked CPU.

If you really like it, I can try to repair it (got the service manual). If it is uneconomical to repair it, there would be no charge.
If you want a similar replacement - I have about a dozen of similar radios (may even have a spare 1402)
Hi there . I am chasing a 1402 possibly a 1480. It would be great if you had one of these to sell.
1991 300CE -24

Post Reply

Return to “I.C.E. Cold - Car Audio”