No hot air from heater

1982-1993 :180E, 190E, 190E 2.3, 190E 2.6, 190D 2.2, 190D 2.5, 190D 2.5 T
Post Reply
User avatar
pva68
C Class
Posts: 46
Joined: Tue 29 Oct, 2013 4:18 pm
Model you own: w114
Location: Sydney

No hot air from heater

Post by pva68 » Wed 27 May, 2015 9:08 pm

I am having a problem in my W201 190E, 1990 model. The heater fan blows but only cold air.
I have checked the operation of the monovalve and visually it appears to be working although it does have a leak.
I have unplugged the heater hoses and forced water through both ways which indicated no block in the heater core (I think).

I ran some radiator flush through and replaced the coolant.

Result, heater blows cold air no matter the engine temp.

So I am asking if there is anything else I should be looking at? The thought of going through winter with no heat is not pleasant
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1973 W114 280CE
1989 W124 300CE
1990 W201 190E (my son thinks this is his car).

CraigB
OZBENZ Admin
Posts: 4760
Joined: Thu 23 Jun, 2005 2:18 pm
Model you own: I own multiple different models
Location: Hawthorndene (Adelaide)

Re: No hot air from heater

Post by CraigB » Thu 28 May, 2015 9:12 pm

When the engine is warm have you felt along the hoses to see if some areas are warm and others not, especially as it warms up. Of course one reason why a heater can go cool is not enough coolant in the system but sounds like you have it covered. Assuming car temp is normal. Also years ago i had hassles with a car on LPG and water not going through the converter thing and it freezes - was an air lock - have you seen anything about air locks and bleeding on your model?
Craig Baulderstone
Lurch
280s's
280SE3.5
280SL
350SL
500SEC's
560SEL's

User avatar
Tony From West Oz
OZBENZ moderator
Posts: 3089
Joined: Mon 20 Jun, 2005 10:04 pm
Model you own: w202
Location: Bedfordale WA

Re: No hot air from heater

Post by Tony From West Oz » Thu 28 May, 2015 9:53 pm

1. Check for voltage on the duo-valve wiring connector while the engine is running. If no voltage, then it is likely that the HVAC controller is U/S.
2. Apply voltage between centre and one side pin on the duovalve valve connector and you should feel hot water flowing to the heater core.
3. Repeat for the other contact and you should have water flow to the other side of the heater core.

You should know where to go next, after these tests.

Tony
Life is a journey, with problems to solve, lessons to learn, but most of all, experiences to enjoy.

'83 W123 300D 325000km (Wife's car Josephine - sold).
'84 W123 300D replaced good OM617 912 with OM617 952 and enjoyed having good acceleration for the first time since first driving a 300D in 2002 - became engine and trans donor for 300CD Turbodiesel conversion. Now parted out.
'86 W124 300D sold (Wife's old car - sold )
'85 W123 300CD, 275 000km (Fatmobile) rebuilt turbodiesel from previous Fatmobile transplanted into 280CE (occasional tourer)
'99 W202 C250 Turbodiesel (my darling Wife's car - Sold)
'98 W202 C250 Turbodiesel (my car - Sold)
'06 Ssanyong Musso Crew Cab 2WD Ute (OM662 diesel and Auto Transmission)

User avatar
John Green
OZBENZ Admin
Posts: 6357
Joined: Mon 20 Jun, 2005 4:49 am
Model you own: w124
Location: Canberra-center of the known universe
Contact:

Re: No hot air from heater

Post by John Green » Fri 29 May, 2015 10:05 pm

I discussed this today with Paul when he rung work. Do any of you W201 guys know if the heater knob on these activates a flap as well as the valve in the engine bay? (by the way I don't actually know everything). The W116's have a system where the heater lever actuates a tap and gradually operates a flap that allows air to pass over the heater core. If the tap opens, but no air passes over the heater core you get no heat....
Save up to 50% on your Mercedes-Benz parts. Phone toll free on 1300 787 300

M.B Spares 14-16 Lyell St, Fyshwick ACT. Please send parts requests to spares@mbspares.com.au not via the forum messenger system.

http://mbspares.com.au

User avatar
Greg in Oz
OZBENZ Admin
Posts: 3210
Joined: Tue 01 Aug, 2006 11:08 pm
Model you own: I own multiple different models
Location: Sydney, Australia

Re: No hot air from heater

Post by Greg in Oz » Mon 01 Jun, 2015 11:34 pm

Yes, the W201 has air blend flaps. There is only a single heater core matrix controlled by a single hot water valve which is either on or off, controlled by vacuum (not an electric mono or duo valve as in the W124 and W126). There are separate heater control knobs for the passenger and driver sides. Turning either knob away from the off (cold) position switches the vacuum supply causing the water valve to open allowing hot coolant to flow. Further rotation of the knobs adjusts the air blend flaps and therefore the amount of hot air that is mixed with cold air and also allows different temperatures for the driver and passenger (in traditional MB fashion).

Correct vacuum operation can be confirmed by observing the operation of the hot water valve (near the wiper assembly in the engine bay). Correct operation of the air blend flaps can be observed by fully opening the fresh air vent in the centre of the dash and shining a light into the vent. The levers that operate the air blend flaps can be seen to move as the heater knobs are rotated.
107023 - 350SLC: 1973, 3sp auto, icon gold, parchment MBtex (sold July 2012 after 29 years ownership)
107026 - 500SLC: 1981, 4sp auto, thistle green, green velour
124090 - 300TE: 1990, 4sp auto, arctic white, cream-beige MBtex
124090 - 300TE: 1992, 4sp auto, malachite (spruce green), black MBtex
201024 - 190E-2.0: 1985, 5sp manual, black, black MBtex
201028 - 190E-2.3 Sportline: 1990, 5sp manual, arctic white, blue leather
201028 - 190E-2.3: 1992, 4sp auto, blueblack, grey MBtex
201028 - 190E-2.3 Sportline: 1990, 4sp auto, signal red, black cloth (parts car)
201034 - 190E-2.3-16 Cosworth: 1985, 5sp manual, blueblack, black leather
YG2S8 - Mini Clubman GT: 1972, 4sp manual, blue, parchment vinyl (my first car which I still own)

Post Reply

Return to “W201”