Car accelerates and brakes not working

If you have a non model specific technical question or some general MB related content, post it here!
Users are requested to Search through relevant topics using the "Search" function, before posting here.
Post Reply
JoeClark
Posts: 1
Joined: Thu 09 Nov, 2017 11:23 pm
Model you own: w189

Car accelerates and brakes not working

Post by JoeClark » Sun 12 Nov, 2017 12:46 am

Hello,

He was hit by a 2000 E320. The driver reports the following:
The car was in cruise control and suddenly there was a beeping sound coming from the vehicle. The ABS light came on followed by the SRS light. The driver tapped the brake to disengage the cruise control. The message display posted
a message "WorkShop NOW". Driver took the next exit and the vehicle started to slow down. While beginning the offramp the driver said the vehicle started to make a strange up and down growling sound. She continued on the off ramp when suddenly the engine revved up and the vehicle accelerated. She put her feet on the brake pedal and she was unable to get the vehicle to slow down even while putting both feet on the brake pedal. It is estimated she was going 65MPH when she hit my grandson's car.

The off ramp was uphill. The car would automatically slow down because of the hill. The sudden acceleration? Maybe the car never went out of cruise control. Is it possible the cruise control was not deactivated by the brakes?


I didn't find the right solution from the internet.
References:

http://www.benzworld.org/forums/general ... rking.html

explainer video

Post Reply

Return to “General Mercedes-Benz related.”