350SL Restore - Follow on from "My First Post"

1971-1989: 280SL, 280SLC, 300SL, 350SL, 350SLC, 380SL, 380SLC, 420SL, 450SL, 450SLC, 450SLC 5.0, 500SL, 500SLC, 560SL
Post Reply
User avatar
iank
E Class
Posts: 59
Joined: Mon 25 Feb, 2008 6:34 am
Model you own: w107
Location: Central Victoria

350SL Restore - Follow on from "My First Post"

Post by iank » Tue 02 Jan, 2018 4:45 pm

Happy New Year fellow "Ozbenzers". Welcome to 2018.


I have started this topic as a follow on to the many helpful (and much appreciated) conversations we have had since I first joined Ozbenz back in February 2008. I can hardly believe it - that is just on 10 years ago, when I was first "getting serious" about "restoring" my beloved 1971 350SL. viewtopic.php?f=13&t=5392&start=50

I thought the original post was not only getting a little unwieldy, but was also somewhat confusingly titled, so time for a new post to cover any further work, and answer a few outstanding comments still to be addressed.

My apologies for "deserting" the forum since last October.

A brief catch up - I had got the car all back together, down off the stands, and running, albeit having problems with idling after it started to come up to operating temperature. Many valuable suggestions were contributed, pretty much all of which I either followed up, or had already attended to. The "problem" one, which was mentioned, was the cold start valve. I had no prior knowledge of how it may stick, or even how it operated.

Having done as was suggested, and removed the unit, and checked its operation with the boiling water test, I soon confirmed it was stuck tight. Having soaked it in kero for a couple of days, drying it with gentle compressed air, repeating the boiling water check indicated it was now opening and closing beautifully. Re installed - the M116 started and ran very smoothly, from cold through to full operating temperature. Once again, many thanks for the advice from the forum members.

I was a "happy camper"!! Repositioned the R107 in the shed, ready for a drive around the paddocks next day!

Hmmmm! Oh dear - next day before starting up I performed my customary "inspection" around (and under) the car. What was that VERY WET patch in the shed gravel? It took no time to realise that the fuel pump was leaking, when running. A most unwelcome, new fault. A close inspection upon removing the pump, showed the body was leaking where swagged onto the electric motor (if I am explaining it correctly??) Anyway, I had not had that problem previously, but I had done some work on the pump itself (as distinct to the electric motor), on this pretty old looking unit (I guess original). So time for a new Bosch fuel pump.

Needless to say, that all delayed the test drive somewhat,by the time I identified, and obtained the correct pump, and installed it (along with some necessary minor mods). Anyway, all done, very successfully, and much peace-of-mind with the new pump.

So, that brings progress report pretty much up to date, except perhaps for a few comments regarding brakes? I will get back to you in the near future with any comments about that work.
iank
1971 350SL
1980 LA911

"Keep enjoying the Journey"
:joker: :coffee2:

User avatar
Mercmad
Mercedes Demigod
Posts: 8043
Joined: Sun 11 Sep, 2005 9:01 pm
Model you own: w109
Location: Brissy
Contact:

Re: 350SL Restore - Follow on from "My First Post"

Post by Mercmad » Wed 03 Jan, 2018 8:49 am

looking at what sort of money the 350 SL is fetching today, you can rest assured that you have not lost any money over the decades you kept your car under cover. :clock: :clock: :coffee2: in fact you might just be making money ... :laughing6:

User avatar
iank
E Class
Posts: 59
Joined: Mon 25 Feb, 2008 6:34 am
Model you own: w107
Location: Central Victoria

Re: 350SL Restore - Follow on from "My First Post"

Post by iank » Thu 04 Jan, 2018 4:01 pm

Good'ay Mercmad,

Many thanks for the comment - that has certainly brightened my day!! :dance:
iank
1971 350SL
1980 LA911

"Keep enjoying the Journey"
:joker: :coffee2:

User avatar
iank
E Class
Posts: 59
Joined: Mon 25 Feb, 2008 6:34 am
Model you own: w107
Location: Central Victoria

Re: 350SL Restore - Follow on from "My First Post"

Post by iank » Wed 14 Mar, 2018 11:18 am

<r>Well, here I am back, about two and a half months later. The "few comments regarding brakes" mentioned in my previous post, can now be delivered!<br/>
<br/>
After far too much mucking around tweeking, checking, bleeding, etc I now have 4 new Rotors and 4 completely overhauled Calipers, a new Master Cylinder, c/w new Reservoir installed and working as necessary to provide the braking system any of us would demand of such a wonderful vehicle.<br/>
<br/>
I have also replaced all instrument cluster globes, and the foot well lamps with the appropriate LED units. They are significantly brighter, and to my eye, make a big improvement. There is also a new Radio / CD / BT unit in the dash. Perhaps may not meet the approval of "traditionalists" but the "original" radio is long gone - before my time!<br/>
<br/>
About all that is left to do is a good body wash then cut and polish, obtain a "Roadworthy" and register on Red Plates I am expecting to arrange this in the next month or two.<br/>
<br/>
I have just put the hard top back on the "baby", but have posted here a few photos of the car taken a couple of weeks ago, while still in "convertible" mode.<br/>
<br/>

Once again, I do thank all of you who have taken an interest in my protracted "restoration" project, and indeed, provided me with so much valued assistance.<br/>
<br/>
Last edited by iank on Sun 18 Mar, 2018 4:42 pm, edited 1 time in total.
iank
1971 350SL
1980 LA911

"Keep enjoying the Journey"
:joker: :coffee2:

User avatar
iank
E Class
Posts: 59
Joined: Mon 25 Feb, 2008 6:34 am
Model you own: w107
Location: Central Victoria

Re: 350SL Restore - Follow on from "My First Post"

Post by iank » Wed 14 Mar, 2018 11:26 am

Image

Image
You do not have the required permissions to view the files attached to this post.
Last edited by iank on Sun 18 Mar, 2018 4:47 pm, edited 2 times in total.
iank
1971 350SL
1980 LA911

"Keep enjoying the Journey"
:joker: :coffee2:

User avatar
iank
E Class
Posts: 59
Joined: Mon 25 Feb, 2008 6:34 am
Model you own: w107
Location: Central Victoria

Re: 350SL Restore - Follow on from "My First Post"

Post by iank » Wed 14 Mar, 2018 11:34 am

<r>Well, here I am back, about two and a half months later. The "few comments regarding brakes" mentioned in my previous post, can now be delivered!<br/>
<br/>
After far too much mucking around tweeking, checking, bleeding, etc I now have 4 new Rotors and 4 completely overhauled Calipers, a new Master Cylinder, c/w new Reservoir installed and working as necessary to provide the braking system any of us would demand of such a wonderful vehicle.<br/>
<br/>
I have also replaced all instrument cluster globes, and the foot well lamps with the appropriate LED units. They are significantly brighter, and to my eye, make a big improvement. There is also a new Radio / CD / BT unit in the dash. Perhaps may not meet the approval of "traditionalists" but the "original" radio is long gone - before my time!<br/>
<br/>
About all that is left to do is a good body wash then cut and polish, obtain a "Roadworthy" and register on Red Plates I am expecting to arrange this in the next month or two.<br/>
<br/>
I have just put the hard top back on the "baby", but have posted here a few photos of the car taken a couple of weeks ago, while still in "convertible" mode.<br/>
<br/>
Image
Once again, I do thank all of you who have taken an interest in my protracted "restoration" project, and indeed, provided me with so much valued assistance.<br/>
<br/>
<IMG src=""><s>Image</e></IMG></r>
You do not have the required permissions to view the files attached to this post.
iank
1971 350SL
1980 LA911

"Keep enjoying the Journey"
:joker: :coffee2:

User avatar
iank
E Class
Posts: 59
Joined: Mon 25 Feb, 2008 6:34 am
Model you own: w107
Location: Central Victoria

Re: 350SL Restore - Follow on from "My First Post"

Post by iank » Sat 17 Mar, 2018 6:38 pm

Image
You do not have the required permissions to view the files attached to this post.
iank
1971 350SL
1980 LA911

"Keep enjoying the Journey"
:joker: :coffee2:

User avatar
edenning
S Class
Posts: 78
Joined: Fri 10 May, 2013 12:15 am
Model you own: w107
Region: South Australia
Location: South Australia

Re: 350SL Restore - Follow on from "My First Post"

Post by edenning » Wed 21 Mar, 2018 9:01 pm

Congratulations Ian on all your hard work and persistence. I trust the car is running much better now and for all the years to come. A wash, cut and polish now will be the most rewarding finish to all your endeavours. Enjoy your beautiful machine.
cheers Evan

User avatar
iank
E Class
Posts: 59
Joined: Mon 25 Feb, 2008 6:34 am
Model you own: w107
Location: Central Victoria

Re: 350SL Restore - Follow on from "My First Post"

Post by iank » Fri 23 Mar, 2018 4:48 pm

Hi Evan,

Many thanks for your congratulations and encouragement. I am yet to get a road permit (in preparation for the Road Worthy) and get it out on a "real" road. So far I am just driving it around the farm. I am sure only then will I get a true sense of how will the 107 is really going, but my feel at present is that not only is it running really well, but feels so much "tighter" in the body, suspension and steering.

I will post again when I have a better idea of its performance.

Yes, it has been a long, drawn-out journey bringing it back from where it was nearly 20 years ago, but that is largely due to the small "bursts" of time I could afford to working on the project, until I retired (from formal employment) at the end of 2016. Mind you, the car doesn't really look much different outwardly from what it did all those years ago, as 99% of my effort was underneath, in the cockpit, and under the bonnet.

Time will tell how it goes!! I'll let the Ozbenzers know. Cheers, Evan.

Regards,
iank
1971 350SL
1980 LA911

"Keep enjoying the Journey"
:joker: :coffee2:

Post Reply

Return to “W107 Coupe and Roadster models”