Transmission oil pump

1971-1989: 280SL, 280SLC, 300SL, 350SL, 350SLC, 380SL, 380SLC, 420SL, 450SL, 450SLC, 450SLC 5.0, 500SL, 500SLC, 560SL
Post Reply
User avatar
450sl
E Class
Posts: 57
Joined: Mon 14 Nov, 2011 1:56 pm
Model you own: w107
Contact:

Transmission oil pump

Post by 450sl » Mon 11 Sep, 2017 6:58 pm

Hi All

I've got a 450 SL and its automatic transmission is being overhauled (722.001 (W 3 B 050) 116 270 1401 041335)

The Primary Oil Pump has the markings 100 277 10 20 and the Transmission shop is of the opinion it needs to be replaced as a 'lip' was created as the 'center ring had fallen out' and thus the housing is worn.

According to my manual, the part# should be 100.277.07.14
And according to EPC it should be 116.270.08.90 it also appears that Mercedes re-manufactured these as 116.270.08.90.81

My questions:
- Is there anybody that is aware of the pump, and the problem described (is it a real problem or is it fine)
- Are the part numbers correct?
- Would a second hand part be ok, or if replace then replace with new?!?

Kind regards
Marco
Marco & Sonia
1978 MB 450 SL
Adelaide
My blog 450sl.blogspot.com

User avatar
Mercmad
Mercedes Demigod
Posts: 8044
Joined: Sun 11 Sep, 2005 9:01 pm
Model you own: w109
Location: Brissy
Contact:

Re: Transmission oil pump

Post by Mercmad » Mon 11 Sep, 2017 9:09 pm

You MUST replace the pump and the convertor spigot (A116 272 09 20 ). The 116 number is the new part for the spigot . Using the spigot again will result in wear and leaks and even result in Spigot failure which will destroy the trans.

Post Reply

Return to “W107 Coupe and Roadster models”