Page 1 of 1

HELP! 560SEC died on the highway and won't start

Posted: Sat 27 Jan, 2018 8:13 pm
by Dean 560 SEC
Hi Guys

Had the opportunity to take the SEC out for a run this morning, it was running beautifully (as usual) then as I approached a set of traffic lights it stalled then wouldn't restart.

It appeared that the fuel pump wasn't firing up so I put it on a tow truck and headed home.

Once home I attempted to fire it up again, turns over, but no fuel pump.

I pulled the Fuel Relay and jumped it - fuel pumps start working. Turns over but still won't fire up.

Reinsert Fuel Relay, turn the key and the pump fires up engine turns over but still won't start.

To check it had spark I attached a timing light and turned the engine over - it appears to fire the light once then nothing.

Any suggestions from previous experience before I get in to it tomorrow morning?

Regards

Dean

Re: HELP! 560SEC died on the highway and won't start

Posted: Sat 27 Jan, 2018 8:38 pm
by MMWA
fuel pump relay will prime on key position 2 for a second or 2 then stop, then should start the pumps in the start position and then keep them running only when a tach signal from the ezl is detected.

I'd be checking if the ezl is even switching the coil anymore and before condemning it, making sure the crank angle sensor is actually working (with a scope) and that the ezl is even getting power.

Sounds interesting regardless, could also be as simple an aftermarket immobilizer malfunctioning and immobilizing you, wouldn't be the first time.

Another thought, if it has twin fuel pumps - the system will not function at all if the primary pump has failed, the secondary will be pulling a vacuum. Make sure there is fuel pressure at the fuel distributor. I have seen this before. They can still make the right noises, draw the right current and deliver zero fuel.

Re: HELP! 560SEC died on the highway and won't start

Posted: Sat 27 Jan, 2018 9:02 pm
by kimrh
Dean - as David said
Usually if no spark when cranking it can be crank sensor/coil gone or worst scenario the EZL has fried itself.
300hp engine 87 model - can't remember of yours is 4 pin ECE with manual fuel trimmer knob settings at false firewall left side or 8 pin RUF with knock sensors?

Re: HELP! 560SEC died on the highway and won't start

Posted: Sun 04 Feb, 2018 7:25 pm
by gazman
G'day Dean, did you find the issue and hopefully sorted

Re: HELP! 560SEC died on the highway and won't start

Posted: Sun 11 Mar, 2018 1:44 pm
by Dean 560 SEC
PROBLEM SOLVED!

Replaced the ignition coil - all back to normal!

Dean

Re: HELP! 560SEC died on the highway and won't start

Posted: Sun 11 Mar, 2018 2:50 pm
by gazman
Good to hear it's back on the road an was an easy fix :wav: