all electric windows not working

1979-1991 280SE, 300SE, 300SEL, 380SE, 380SEL, 380SEC, 420SE, 420SEL, 420SEC, 500SE, 500SEL, 500SEC, 560SEL, 560SEC
Post Reply
CraigB
OZBENZ Admin
Posts: 4810
Joined: Thu 23 Jun, 2005 2:18 pm
Model you own: I own multiple different models
Location: Hawthorndene (Adelaide)

all electric windows not working

Post by CraigB » Sat 09 Dec, 2017 12:26 am

I tried searching this - lots of things about electric windows but couldn't find this problem. This is on a 1982 500SEC and out of nowhere all electric windows stopped working. I checked a few things like fuses and loose connectors - but all out at once I thought limited sources. Checked out wiring diagram and got the idea about relays - E and F are the ones related to the windows. I swapped in a spare and found 'F' was the problem - all fixed but wish i had tried relays before pulling the console apart to get to plugs on switches! Hope this post saves someone else the hassle. And to ID relay letter, it is faintly cast into the fusebox like the fuse numbers and also if you pull them out it is written underneath quite clearly.
Craig Baulderstone
Lurch
280s's
280SE3.5
280SL
350SL
500SEC's
560SEL's

Honey500
Pagoda
Posts: 125
Joined: Mon 08 Feb, 2016 9:32 am
Model you own: w126
Location: Adelaide

Re: all electric windows not working

Post by Honey500 » Mon 11 Dec, 2017 12:36 pm

Hi Craig,

Thanks for the post, quite helpful. I take it though that if it is the relay none of the windows work? Rather than the 1 window that is not working on my series 1.
It is easier to ask forgiveness than it is to ask for permission!

1985 500sec aka Sadie (current project)

CraigB
OZBENZ Admin
Posts: 4810
Joined: Thu 23 Jun, 2005 2:18 pm
Model you own: I own multiple different models
Location: Hawthorndene (Adelaide)

Re: all electric windows not working

Post by CraigB » Mon 11 Dec, 2017 1:22 pm

Yes that's right. For trouble shooting one window I would pull the switches from the console and swap them left to right - basically you just want to be able to take the plug from the window not working and plug it in to another switch - it will fit the other side. If it works, you can pull the other switch apart and clean up contacts etc or buy a new one. If it makes no difference then you are probably looking at a motor thing. If you have a multimeter you can check if power coming through to motor etc.
Craig Baulderstone
Lurch
280s's
280SE3.5
280SL
350SL
500SEC's
560SEL's

Honey500
Pagoda
Posts: 125
Joined: Mon 08 Feb, 2016 9:32 am
Model you own: w126
Location: Adelaide

Re: all electric windows not working

Post by Honey500 » Mon 11 Dec, 2017 1:46 pm

Thanks Craig.

Was chatting to a mate re: testing with a multi meter. Knowing my car I will probably open up th door and find no motor at all!!!!
It is easier to ask forgiveness than it is to ask for permission!

1985 500sec aka Sadie (current project)

CraigB
OZBENZ Admin
Posts: 4810
Joined: Thu 23 Jun, 2005 2:18 pm
Model you own: I own multiple different models
Location: Hawthorndene (Adelaide)

Re: all electric windows not working

Post by CraigB » Mon 11 Dec, 2017 2:02 pm

easy first test though, just lever out the switches and do some swapping before you pull anything else apart - could just be a dirty switch or even a wire off.
Craig Baulderstone
Lurch
280s's
280SE3.5
280SL
350SL
500SEC's
560SEL's

Honey500
Pagoda
Posts: 125
Joined: Mon 08 Feb, 2016 9:32 am
Model you own: w126
Location: Adelaide

Re: all electric windows not working

Post by Honey500 » Tue 16 Jan, 2018 12:17 am

Ok so need some advice from the brains trust.

Today on a perfect Adelaide summers day took Sadey out for a decent run and became inspired to do some work on the busted front window when I got home. Have checked switches and appears to be an issue with the motor. I got the multi meter out and when operating the switch I get 12v on the elec contacts so I conclude it is the motor. Undid 2 screws in the botom and then basically unscrewed the unit.

Question is based on the pic is this all I need to remove? Doesn't seem big enough.

Second question is whether it is worth heading out to upullit (pick a part) and removing a motor? Any way of testing that motor without taking a car battery with me?
You do not have the required permissions to view the files attached to this post.
It is easier to ask forgiveness than it is to ask for permission!

1985 500sec aka Sadie (current project)

CraigB
OZBENZ Admin
Posts: 4810
Joined: Thu 23 Jun, 2005 2:18 pm
Model you own: I own multiple different models
Location: Hawthorndene (Adelaide)

Re: all electric windows not working

Post by CraigB » Tue 16 Jan, 2018 8:45 am

i don't know but would imagine the motor is same as sedans and there is usually at least one of those at upullit - can check stock list too. That's all you need I think. And testing, there is usually a rack of batteries for sale at upullit - just need a couple of wires! And if the same, I would take a back window motor or at least passenger side.
Craig Baulderstone
Lurch
280s's
280SE3.5
280SL
350SL
500SEC's
560SEL's

Honey500
Pagoda
Posts: 125
Joined: Mon 08 Feb, 2016 9:32 am
Model you own: w126
Location: Adelaide

Re: all electric windows not working

Post by Honey500 » Tue 16 Jan, 2018 9:30 am

Thanks Craig, last time I visited there were a few. Sounds like a trip might be in order!
It is easier to ask forgiveness than it is to ask for permission!

1985 500sec aka Sadie (current project)

420 SE
OZBENZ Admin
Posts: 2247
Joined: Tue 30 Aug, 2005 6:54 pm
Model you own: w126
Location: Gold Coast - Q, AU, & Doha, Qatar

Re: all electric windows not working

Post by 420 SE » Tue 16 Jan, 2018 3:02 pm

From memory, there are two different motors which were used.

It would pay to take your broken one for comparison.
Ross
"I don't know, it's just some random dude..."

220 SEb - 1962 (Hilda - sadly gone to which there is no return)
420 SE - 1988 (Lucy) - back into service!
ML 500 - 2008 (the Doha desert Dame) - retired
ML 400 - 2015 (the new Doha desert Dame, or is that Princess?)
A couple of others not worth mentioning

Beware of fundamentalists
#73

The 126 - undoubtedly the last, best large body MB

Honey500
Pagoda
Posts: 125
Joined: Mon 08 Feb, 2016 9:32 am
Model you own: w126
Location: Adelaide

Re: all electric windows not working

Post by Honey500 » Tue 16 Jan, 2018 8:30 pm

Good suggestion, thanks Ross
It is easier to ask forgiveness than it is to ask for permission!

1985 500sec aka Sadie (current project)

User avatar
Dean 560 SEC
Ponton
Posts: 238
Joined: Tue 15 Sep, 2015 8:28 pm
Model you own: w126
Location: Perth Western Australia

Re: all electric windows not working

Post by Dean 560 SEC » Wed 17 Jan, 2018 1:29 pm

If youre after a front left SEC window motor I should be able to help you with one.

Regards

Dean
Current Garage
1987 560 SEC (ECE)
1982 XJ6 Jaguar
2007 E90 BMW 530i
2004 E46 BMW 318i

Post Reply

Return to “W126”