W123 300d

Newcomers Please stop here first.
A wealth of information here to help you find your way through OZBENZ Forums
Post Reply
User avatar
B Class
Posts: 15
Joined: Mon 09 Oct, 2017 3:50 pm
Model you own: w123
Location: Wheat belt WA

W123 300d

Post by Thunderbolt » Sat 28 Oct, 2017 3:34 pm

Hi all just bought an 83 w123 300d and love it! Had some issues bad shaking motor (valve adjustment rear mount) central locking (busted vac hose) bad flaring shifts (red/black and green/black vac hoses on rocker cover valve wrong way round) goes great now. I bought a 6 cyl petrol non runner as parts car wich I havent picked up yet. Anyway great forum

User avatar
Tony From West Oz
OZBENZ moderator
Posts: 3143
Joined: Mon 20 Jun, 2005 10:04 pm
Model you own: w202
Location: Bedfordale WA

Re: W123 300d

Post by Tony From West Oz » Sat 28 Oct, 2017 11:00 pm

Welcome to the forum Thunderbolt. It sounds like you have the 300D vacuum system sorted out. I have 16 years experience owning and maintaining our 300Ds so if you have a problem, please post it on the forum. If I can't help, plenty of others may have the answers.

Life is a journey, with problems to solve, lessons to learn, but most of all, experiences to enjoy.

'83 W123 300D 325000km (Wife's car Josephine - sold).
'84 W123 300D replaced good OM617 912 with OM617 952 and enjoyed having good acceleration for the first time since first driving a 300D in 2002 - became engine and trans donor for 300CD Turbodiesel conversion. Now parted out.
'86 W124 300D sold (Wife's old car - sold )
'85 W123 300CD, 275 000km (Fatmobile) rebuilt turbodiesel from previous Fatmobile transplanted into 280CE (occasional tourer)
'99 W202 C250 Turbodiesel (my darling Wife's car - Sold)
'98 W202 C250 Turbodiesel (my car - Sold)
'06 Ssanyong Musso Crew Cab 2WD Ute (OM662 diesel and Auto Transmission)

Post Reply

Return to “Welcome to OZBENZ!”